[Bglug] Dell Precision 380 - now boots into Linux

Chris Clark stars at unitedwaybg.com
Thu Jun 14 12:19:32 EDT 2018


Peter,
Sounds Like Fun, reminds me of installing PCLinuxOS the first time.
I was thinking I might have to install with another machine and move the
HDD over 1 at a time.
*Will it boot to pxe ???*
Thanks !!

On Mon, Jun 11, 2018 at 9:04 PM, Peter <pjr at bmts.com> wrote:

> Hello Chris:
>
> I got Linux Mint Maya installed and booting - finally.
>
> The box I borrowed from STARS has a SATA (Samsung SP0411C/R, sda, 40 HB
> SATA, 7200 rpm, D0 in BIOS) as well as 2 IDE ( ST3082110A, 80 GB, IDE D4 in
> BIOS, and a cd/dvd drive) drives and a 3.5 inch diskette drive. One site in
> my research said that Dell shipped the IDE drives jumpered as Cable Select
> but their installations only worked if they were jumpered as Master &
> Slave. I did not change anything here and I don't know how mine were
> jumpered. The Dell Precision 380 dates somewhere on or after 2006 but is a
> nice machine, nonetheless.
>
> The 3.5 inch always showed its light on. I tried the ancient thing of
> turning the connector over (in the days before keyed connectors, having the
> drive light always on was a sign it was on backwards) - no change, so I
> unplugged it and turned it OFF in the BIOS. And I don't have any diskettes
> to try in it, anyway.
>
> The box was not happy if the SATA drive was disconnected and would not
> boot.
>
> UNETBOOTIN on a USB stick did not work.
>
> I put the Maya cd in the drive and changed the boot order in BIOS and it
> booted OK. Then I installed Linux. All appeared to go well, but it would
> not boot. I tried a System Rescue Disk and a Knoppix disk and I could see
> all the Linux files were on the SATA drive, sda. But no boot. Tried the
> update-grub (I can never remember if it's update-grub or grub-update!) but
> it complained that I was attempting to change a read-only file several
> tries and an error message  which I've forgotten. Othere people reported
> similar messages. Several times it appeared to be booting and stopped;
> hitting ctrl-esc showed the last activity was starting the cups printing
> server. Tried the Boot Repair disk - it reported success and finished, but
> no boot. Note, for the installation of Maya, I did the manual ('something
> else') install and partitioned the drive as 100 MB for /boot, 10 GB for /,
> 5 GB for swap area, and the rest as /home. This is my usual process so I
> can change the OS version and not lose my /home files. But I still make a
> backup just in case when I upgrade even though I've never had to use it.
>
> So, I went back to square one, as they say. Put the Maya cd in and ran the
> live version. I deleted the existing partition table and created a new one
> using GPARTED. Then I installed Maya again. This time I told it to erase
> the disk and take it all for the installation, except it wanted a swap
> area, so I gave it 5 GB for that. Installation went OK as before. Then,
> wonders never cease, it rebooted after I restarted it (soft one, ie no
> power off). Then I did the update. Many new files, including LibreOffice -
> is that normal? Shutdown (hard, power off) and reboot. Success! Repeated
> the shutdown/restart several times OK.
>
> In summary: I turned off the diskette drive, made sure the SATA drive and
> the IDEs were plugged in, tried several times with the cd boot process and
> did not pre-partition the drive but let Maya take it over.
>
> If I do it again, I might try putting /home on the IDE drive, but that
> will come much later, if at all. Also, I might try Ubuntu 18, just for
> giggles.
>
> Peter Richards
>
> --
> Two things are infinite: the universe and human stupidity; and I'm not
> sure about the the universe. -  Albert Einstein
>
>
> _______________________________________________
> Group mailing list
> Group at bglug.ca
> http://bglug.ca/mailman/listinfo/group_bglug.ca
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://bglug.ca/pipermail/group_bglug.ca/attachments/20180614/019c5133/attachment.html>


More information about the Group mailing list